Info:

twitter

Ultimi commenti: Comment feed

Tags:

Archivio 2017:

Mag Apr Mar Feb Gen

Archivio 2016:

Dic Nov Ott Ago Mag Mar Feb Gen

Archivio 2015:

Nov Ott Set Mar Gen

Archivio 2014:

Dic Nov Ott Set Lug Giu Mag Apr Gen

Archivio 2013:

Dic Nov Set Ago Lug Giu Mag Apr Feb Gen

Archivio 2012:

Dic Nov Ott Set Ago Giu Mag Apr Mar Feb Gen

Archivio 2011:

Dic Nov Ott Set Ago Lug Giu Mag Apr Mar Feb Gen

Archivio 2010:

Dic Nov Ott Set Ago Lug Giu Mag Apr Mar Feb Gen

Archivio 2009:

Dic Nov Ott Set Ago Lug Giu Mag Apr Mar Feb Gen

Archivio 2008:

Dic Nov Ott Set Ago Lug Giu Mag Apr Mar Feb Gen

Archivio 2007:

Dic Nov Ott Set Ago Lug Giu Mag Apr Mar Feb Gen

Archivio 2006:

Dic Nov Ott Set Ago Lug Giu Mag Apr Mar Feb Gen

Installazione di Ubuntu 6.10 su un Virtual PC

(Update: Per la versione 7.04 fare riferimento a questo post

In passato ho sempre desiderato provare ad installare Ubuntu in una Virtual PC ma l'installazione di default non ha mai funzionato in maniera user friendly. Quando mi andava bene ottenevo una schermata abbastanza ingarbugliata; quando mi andava male il Virtual PC semplicemente si congelava senza più reagire.

Ravanando in giro ho trovato un paio di link utili che mi hanno portato a scrivere questa mini guida:

  1. Innanzitutto è abbastanza penoso cercare di usare l'immagine ISO di default. La soluzione migliore è di usare l'immagine ISO alternativa, quella chiamata "Alternate install CD" nel flavor PC (Intel x86)
  2. Una volta avviato il Virtual PC scegliere nel menu iniziale, via F4, una modalità video a 16 bit colore (l'ultimo numero deve essere insomma 16) come quelle evidenziate nella figura qui in basso:
  3. Fatto questo avviare l'installazione guidata in modalità testo. Seguire il wizard (abbastanza lungo) e attendere la copia dei file sull'HD
  4. Al primo riavvio, durante il menu iniziale, premere ESC e scegliere l'avvio in recovery mode
  5. Al prompt di root eseguire il seguente comando che cambia la modalità grafica di default a 16bit (Virtual PC non supporta i 24 bit ed Ubuntu non sembra accorgersene)
    sed -e 's/DefaultDepth.*24/DefaultDepth 16/g' -i /etc/X11/xorg.conf
  6. riavviare con
    reboot
  7. attivare la scheda di rete. Dal menu system cliccare su networking

    Cliccare properties e li cliccare Enable this connection

    Confermare con OK e chiudere la finestra
    Attivare infine la spunta a sinistra di Wired Connection
  8. attivare la scheda audio: questo si fa aggiungendo la seguente linea al file /etc/modules seguita da invio:
    snd-sb16
  9. riavviare

I più avventurosi possono installare anche le Virtual Machine Additions for Linux. Nella mia macchina virtuale funziona quasi tutto ad esclusione dell'integrazione del mouse (che incidentalmente era la feature che mi interessava di più). Il mio consiglio è di lasciar perdere perché il primo update di sistema ha cancellato tutto (*).

Per farlo seguire i seguenti passi:

  1. scaricare ed installare le VM additions for Linux via http://connect.microsoft.com
  2. installare le librerie di base via apt con il seguente comando
    sudo apt-get install build-essential linux-headers-`uname -r` gcc-3.4'
  3. installare alien (il package converter) via seguente comando
    sudo apt-get install alien
  4. caricare l'immagine delle VM additions installato; il file si chiama VMAdditionsForLinux.ISO
  5. lanciare i seguenti comandi via terminale:
    mkdir ~/vma
    cd ~/vma
    cp /media/cdrom0 .
    for rpm in $(ls *.rpm) ; do sudo alien $rpm ; done
    for i in $(ls *.deb); do sudo dpkg -i --force-overwrite $i ; done
    sudo ./vmadd-install.run all
    sudo /etc/init.d/vmadd start
    sudo reboot

A questo punto le VM additions saranno installate.

Un po' di link utili:

Alcune note su come installare Ubuntu su VPC 2004 (funziona anche con 2007)

Guida passo passo su come installare Ubuntu via modalità testo (passo 3. della mia prima guida di questo post)

Due note su come installare le VM additions

Spero questo post sia utile: diciamo che installare Ubuntu (ma anche SuSe) su Virtual PC (**)  non è proprio una passeggiata!

Enjoy

-quack

(*) in tali casi è sufficiente digitare da terminale i seguenti comandi (o magari creare uno script apposito) per ripristinare la situazione:

  • cd ~/vma
  • sudo ./vmadd-install.run all
  • sudo /etc/init.d/vmadd start
  • sudo reboot

(**) leggo in giro che VMWare server (gratuito) potrebbe risultare più semplice per questi scopi. Mi riprometto di provarci

 

Technorati tags: ,

Potrebbero interessarti anche:
Commenti (34): [ Pagina 1 di 2  - più vecchi ]
5. pluto
lunedì 26 marzo 2007 alle 8:40 AM - unknown unknown unknown
   
   
6. Paperino
lunedì 26 marzo 2007 alle 8:54 AM - unknown unknown unknown
   

OMG Sad

   
7. Nerocicuta
lunedì 26 marzo 2007 alle 12:03 PM - unknown unknown unknown
   

sorry Paperino... di KillerApps per Linux non ne conosco, cioè ti direi Apache, MySql ecc pero' queste vanno anche su altri SO.. io linux lo installo solo per studio diciamo, giusto per vedere com'è..

| Windows Vista User |

   
8. realtebo
lunedì 26 marzo 2007 alle 7:03 PM - unknown unknown unknown
   

personalmente ho provato innotek virtual box con ubuntu 6.10 e va una meraviglia, peccato solo che V.B. non supporti il cambio della risoluzione al volo...

come si fa a dire ad ubuntu di fare un cambio di risoluzione al riavvio successivo !?

   
9. Paperino
martedì 27 marzo 2007 alle 3:59 AM - unknown unknown unknown
   

VirtualBox mi sembra un prodotto troppo nuovo rispetto a Virtual PC (ex Connectix) e VMWare. Sembrerebbero peccati di gioventù.

   
10. realtebo
martedì 27 marzo 2007 alle 8:48 AM - unknown unknown unknown
   
Peccati di gioventù ? Funziona ! E' gratis, qual'è il peccato, scusa?
   
11. Paperino
martedì 27 marzo 2007 alle 4:56 PM - unknown unknown unknown
   

@realtebo:

parlavi del fatto di non supportare il cambio di risoluzione al volo.

   
12. realtebo
mercoledì 28 marzo 2007 alle 1:58 PM - unknown unknown unknown
   
Ah, si, è vero. Ho fatto il bugtrack, speriamo che conti
   
13. H5N1
martedì 17 aprile 2007 alle 5:42 PM - unknown unknown unknown
   
Installando KDE (Kubuntu) è possibile usufruire dell'utilità di impostazione dei servii simile alla console di Windows ed impostare wmadd in avvio automatico. Questo per chi non amasse la linea di comando... :)
   
14. Paperino
martedì 17 aprile 2007 alle 5:55 PM - unknown unknown unknown
   

Ciao H5N1, il problema non è tanto l'impostazione del servizio in automatico, ma il fatto che il servizio non funziona (cioé il mouse viene comunque intrappolato). Se riesci a trovare una combinazione di passi che fa funzionare tale feature ti sarei davvero grato.

   
15. H5N1
venerdì 20 aprile 2007 alle 9:11 PM - unknown unknown unknown
   
Funziona, funziona... :) Solo che funziona solo dopo aver riavviato X!!! (Ctrl+Alt+Backspace) :) Provare per credere. Il mio problema invece consiste nel far riconoscere il Microsoft Generic PS/2 Mouse come dotato di rotellina e... farla funzionare.
   
16. Paperino
venerdì 20 aprile 2007 alle 9:41 PM - unknown unknown unknown
   

Mmmm sono sicuro di aver riavviato X e pure tentato un full reboot. Hai seguito i passi indicati da me o qualche altro tutorial? Potrei provare con la nuova versione visto che avevo voglia di testarne le novità.

   
17. H5N1
sabato 21 aprile 2007 alle 7:11 AM - unknown unknown unknown
   
Ho installato solo il vmadd-full, mi sono assicurato che il daemon (o "servizio"... azz linux comincia a parlare windows... no no...) fosse caricato all'avvio (init.d) e controllato che i driver del mouse fossero quelli contenuti nel pacchetto. Dopodichè per sicurezza ho inserito uno script (sh) in avvio automatico (contenuto: /etc/init.d/vmadd start, semplicemente). Non si sa mai, mai fidarsi di M$. Per installarlo ho trasformato il pacchetto rpm in deb con il comando sudo alien *.rpm --script -d in questo modo dovrebbero venir ricompilati anche gli script. Poi ho utilizzato il pacchetto deb come in qualsiasi altra installazione. E comunque genera errore! :) Ho dovuto anche riparare apt-get :) Però funziona... Ma non mi è di molta utilità :(
   
18. Giancky
sabato 21 aprile 2007 alle 3:11 PM - unknown unknown unknown
   
Non riesco ad usare il mouse su Virtual Pc con Kubuntu 7.04. Il mouse non si muove proprio, non si integra. Che fare? Grazie
   
19. Paperino
sabato 21 aprile 2007 alle 4:51 PM - unknown unknown unknown
   

Giancky, purtroppo non ne ho la più pallida idea. Proverò la 7.04, ma uso Gnome invece di KDE. Magari qualche lettore esperto ti può rispondere qui.

Se trovi la risposta altrove, mettici un link così tengo il post aggiornato per futuri sviluppi.

   
20. H5N1
domenica 22 aprile 2007 alle 12:43 PM - unknown unknown unknown
   
Sto cercando una soluzione... :) Sembra che Virtual PC non si accorga proprio della presenza di un sistema operativo in funzione e quindi non rilasci il controllo del mouse a favore del sistema guest.
   
21. Paperino
domenica 22 aprile 2007 alle 5:36 PM - unknown unknown unknown
   

Mmmm. Virtual PC non deve accorgersi del SO ospite. Quello che penso è questo: il mouse emulato da Virtual PC sia incompatibile (o non supportato correttamente o semplicemente un baco) con la 7.04

Prova una scansione HW e vedi se Ubuntu rileva il mouse. In quel caso si tratta magari di riutilizzare il driver "vecchio".

Sarebbe interessante provare con Virtual Box/VMWare: emulano hardware diverso e magari è meglio supportato.

Questa mi sembra la teoria più semplice. Non posso fare prove al momento ma teniamo il post aggiornato. Poi magari ne creo uno separato con le istruzioni specifiche.

   
22. Paperino
domenica 22 aprile 2007 alle 9:29 PM - unknown unknown unknown
   

Trovato! È un sembrerebbe questo bug del kernel:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=223606

È stato aperto un baco anche nel BTS di Ubuntu (link migliore per seguire l'evoluzione della situazione):

https://bugs.launchpad.net/ubuntu/+bug/109027

Probabilmente uscirà una fix o un update minore della distro.

   
23. H5N1
mercoledì 25 aprile 2007 alle 11:11 AM - unknown unknown unknown
   
Ho provato ad installare VirtualBox. Problemino!!! Crash del Sistema operativo! L'errore è causato dal modulo sfsync04.sys: il StarForce Protection Synchronization Driver.  :)
   
24. Paperino
mercoledì 25 aprile 2007 alle 6:50 PM - unknown unknown unknown
   

@H5N1: mi son preso la libertà di rimuovere un pezzo del tuo commento Smile

Anyway: sei sicuro che starforce sia installato da VirtualBox? mi sembra strano che venga installato da un sw gratuito. magari va semplicemente in conflitto...

   
25. H5N1
giovedì 26 aprile 2007 alle 8:58 PM - unknown unknown unknown
   
No, no... forse mi sono espresso male. Lo StarForce lo avevo installato per via di prodotti che ne facevano uso (e che non utilizzo da tempo). La stessa software house che lo ha sviluppato mette a disposizione un tool per la sua rimozione sul sito onlinesecurity-on.com (che guarda caso) appartiene ad un certo webmaster@star-force.com ^_^ Comunque il problema consisteva in un conflito fra i driver virtuali di VirtualBox e il driver StarForce. Rimosso. Finalmente ho provato Ubuntu 7.04!!! Su VirtualBox funziona anche il mousewheel, viene supportata la condivisione delle cartelle fra host e guest e non c'è bisogno di configurare nessun xorg.conf ^_^ Certo, capisco che non è carino che io venga a parlare della concorrenza, ma credo che la pubblicità comparativa sia democratica! :D
   
26. Paperino
giovedì 26 aprile 2007 alle 9:42 PM - unknown unknown unknown
   

Parlare della concorrenza (parli di VPC, Linux, cosa?) senza mandarsi a quel paese - come stiamo appunto facendo - va benissimo (tra l'altro come puoi leggere in giro stavo facendo un po' di prove comparate anche io). Ne parlo anche io (ho pure consigliato ad altri di provare virtualbox). Lo proverei anche io ma - usando già Virtual PC con 4 o 5 VM - si creerebbe qualche conflitto di driver se vi ci aggiungo Virtual Box.

La parte di commento che ho "censurato" riguardava la rimozione di StarForce che - pensando fosse un hackeraggio - non condono. Smile Tutto qui.

   
27. H5N1
domenica 29 aprile 2007 alle 11:10 AM - unknown unknown unknown
   
Sto usando VirtualPc 2007 e VirtualBox contemporaneamente senza riscontrare conflitti di driver. Per quanto riguarda l'"hackeraggio": c'è hacking e hacking. Mi spiego: se una cosa non funziona e mi è vietato per contratto manometterla ovviamente chiedo supporto al produttore. Se il supporto non è fornito o non riesce a risolvere il problema, "manomettendo" la cosa (bene materiale o immateriale che sia) non commetto alcun reato (almeno non ancora, in Italia), ma semplicemente violo le condizioni contrattuali. In questo caso il tool StarForce Protection Synchronization Driver mandava in crash il sistema durante l'installazione di VirtualBox. Soluzione: rimuoverlo. Se non avessi trovato il tool ufficiale avrei fatto ricorso alla rimozione manuale dei file e delle chiavi di registro. :D
   
28. Marco
sabato 18 agosto 2007 alle 5:47 PM - unknown unknown unknown
   

Salve a tutti

premetto che sono totalmente asino in materia di Linux e questa è la mia prima affacciata a questo nuovo mondo.

Ho lo stesso problema del mouse che non si muove, rimane congelato. E vedero il bug reporting su

bugzilla.redhat.com/.../show_bug.cgi

ok, tutto chiaro... ma come faccio a installare se non mi funziona sto maledetto mouse? come sostituisco il kernel con quello in cui hanno risolto il bug?(che tra l'altro avevo anche intenzione di compilare)

Please help...

   
29. wtf
lunedì 20 agosto 2007 alle 3:49 PM - unknown unknown unknown
   

premi alt+F2

ti logghi con nome utente e password

digiti

sudo apt-get install linux-686

invio e attendi

Ciao.

   
30. delca85
martedì 25 settembre 2007 alle 8:46 AM - unknown unknown unknown
   

Ciao Paperino!Ho installato tutto seguendo la tua guida (grazie!!!!!!!) ma per quanto riguarda il cambiamento della modalità grafica di default il comando che a me funziona è questo: sudo sed 's/DefaultDepth\t24/DefaultDepth\t16/g' /etc/X11/xorg.conf > /tmp/xorg.conf && sudo cp /tmp/xorg.conf /etc/X11/xorg.conf && sudo killall Xorg

mentre il tuo no.

Ciao e grazie ancora!!

   
31. delca85
martedì 25 settembre 2007 alle 9:45 AM - unknown unknown unknown
   

Non riesco ad attivare la scheda audio perchè mi dice che non ho i privilegi per salvare il file che dovrei modificare!

Mentre se cerco il file da root non me lo trova!!

   
32. Alessandro
domenica 31 agosto 2008 alle 10:38 AM - unknown unknown unknown
   

Ciao io avrei un problema..

Io ho fatto tutto quello che mi hai detto tu, ma quando avvio in text mode rimane una schermata nera... Che cosa devo fare ??

Grazie

   
33. fedro
lunedì 26 gennaio 2009 alle 8:24 PM - unknown unknown unknown
   

 installare ubuntu 6.10 su virtual pc 2007 ubuntu visto che e gratis si puo installarlo senza fare niente non esiste il dischetto di linux quindi per  questo e gratis non si paga linux !!!

grazie buon lavoro ciao ciao!!!!!

   
34. fedro
lunedì 26 gennaio 2009 alle 8:30 PM - unknown unknown unknown
   

boh non lo so cosa devi fare e stai parlando di ubuntu linux per usarlo su virtual pc

 

ti si e rotto il computer      ma che schermata nera quella di installazione che ti fa sciegliere cosa vuoi

   
[ Pagina 1 di 2  - più vecchi ]
Lascia un commento:
Commento: (clicca su questo link per gli smiley supportati; regole di ingaggio per i commenti)
(opzionale, per il Gravatar)