Downgrading to Mac #2

[updated]

La seconda puntata della saga si è conclusa molto prima di quanto avessi potuto minimamente immaginare: sono riuscito a comprare un MacBook Pro 2,2 (così è indicato nella schermata "My Mac") dotato di 3GB di RAM, 120GB di HD e scheda ATI x1600 256MB che inconsciamente ho preferito alla "nuova" NVidia; il tutto per la cifra di $1250, affare che ho potuto concludere grazie alla sezione Seattle di Craigslist. Il tipo che me l'ha venduto era un po' "fatto" e si è dimenticato di darmi la password: poco male perché l'upgrade a Leopard era praticamente inevitabile. Le prime impressioni sono state un po' deludenti visto che mi ero preparato per un approccio it just works; Leopard si è installato senza problemi dopo qualche idiosincrasia iniziale: dopo aver inserito il DVD di installazione e aver premuto INSTALL mi veniva chiesta la password che non avevo. Scetticamente ho lanciato l'applet Startup Disk pensando che anche per quello sarebbe stata richiesta la password, ma niente. A quel punto un gran bel formattone e installazione flawless di Leopard: chi dice che i formattoni non sono richiesti per Mac?

Passo successivo Boot Camp: impressionantemente semplice, partiziono il disco, infilo il DVD di Vista SP1 fresco di MSDN/masterizzazione e anche Vista si installa senza grandi problemi. La prima cosa che ho fatto è stata quella di guardare l'indice delle prestazioni.

Il mio vecchio Dell:

DELL index

il mio "nuovo" Mac:

MAC index

La differenza tra la ATI x1300 e la ATI x1600 è notevole e tutto sommato per essere un downgrade non mi posso assolutamente lamentare.

Vista su Mac ha avuto qualche piccolo problema e credo che sia correlato con il fatto che il firmware sia EFI anziché il buon vecchio BIOS. L'esperimento successivo è stato quello di tentare il porting dei miei setting usando le capacità di backup/restore di WHS. L'EFI si è di nuovo messo tra i piedi ed è stato praticamente impossibile fare il boot da CD visto che il CD, in presenza di una installazione Windows, richiede la pressione di un tasto ma la tastiera non viene riconosciuta se non successivamente. Mistero. Poco male: ho cancellato la partizione Vista e riavviato via CD. Dopo un'ora tutto era quasi esattamente come prima: le icone del desktop però sono state letteralmente sconquassate dal fatto che, prima che Vista installasse i nuovi driver, la risoluzione video era stata settata temporaneamente a 800x600. Installati tutti i driver tutto ha ripreso a funzionare a meraviglia e la riduzione di risoluzione da 1680x1050 a 1440x900 non è stata così drammatica come avrei immaginato: tutto sommato i miei gadget sulla sidebar ci stanno ancora tutti. Successivamente mi son imbattuto con la WPA: anche qui niente di tragico considerando che ho legittimamente riattivato via telefono la licenza del desktop almeno una ventina di volte:

activation

phone activation

Note positive: le prestazioni del nuovo sistema sono niente male, la tastiera retroilluminata, il trackpad multitouch che ha lo scrolling più ergonomico di uno normale, il microfono e la webcam, l'alimentatore carino, l'uscita video DVI.

Note negative: il layout della tastiera assurdo (torna a casa DEL! trovato: fn+BACKSPACE) il sistema di caricamento del DVD, la quasi totale assenza di porte USB (2 sono meno del minimo!), l'expresscard da 34 mm anziché di una più classica da 54 mm che non mi permette di usare il mio lettore di smartcard e la totale assenza di lettore multimediale. A quest'ultimo si può ovviare tramite via expresscard, ma per le smartcard sono costretto ad usare il vecchio metodo del guinzaglio USB

Rimane qualche problemuccio da risolvere:

  1. passando da OSX a Windows e viceversa l'ora di sistema è sfasata. Questo è dovuto al fatto che Windows e OSX la memorizzano in maniera diversa nel RTC (Windows usa l'ora locale, OSX usa l'ora universale). Questa soluzione sembra migliorare le cose ma non troppo.
  2. ogni tanto il reboot non funziona e al riavvio vengo accolto da una schermata nera. Credo che anche questo sia collegato al firmware EFI.
  3. il mancato funzionamento della tastiera durante il boot di Windows. Questo è sicuramente il più antipatico dei tre problemi. Sembra che caricare i driver di bootcamp su Vista abbia in qualche modo risolto il problema.

Intanto le prime esperienze con OSX confermano in toto alcune mie teorie. Il prossimo passo è quello di sostituire l'hard disk poco capiente per reggere due OS: con un 160GB o un 250GB, resta ancora da decidere. Questo mi darà anche l'occasione di testare Time Machine da vicino. Qualcuno vuol comprare il mio DELL autografato?

To be continued...

-quack

Technorati tags: ,

Potrebbero interessarti anche:
Commenti (34): [ Pagina 1 di 2  - più vecchi ]
5. Paperino
lunedì 2 giugno 2008 alle 2:08 AM - unknown unknown unknown
   

@Nickelgreen:

non c'e' bisogno di dirle in un orecchio. Presto prenderanno forma direttamente su questo blog.

@Franco:

stranamente la tastiera dopo il boot ha ripreso a funzionare: pensavo di aver aggiornato il post ma evidentemente non ho cliccato pubblica. Pero' il problema dello schermo nero si presenta una volta su 3 o 4: ti e' mai capitato?

@Edward:

E' un 2.33Ghz, un T7600 per la precisione. Per l'RTC provero' a chiedere in giro: se c'e' qualche problema di compatibilita' qualche anziano lo sapra'.

Per i driver c'e' davvero da portarsi una tanica di benzina presso gli OEM e guardare lo spettacolo. Questi giorni faccio le dovute prove, dopo aver deinstallato il WHS connector: se lo score e' piu' alto vorra' dire che il laptop lo vendo ancora piu' velocemente.

   
6. Micky
lunedì 2 giugno 2008 alle 7:04 AM - unknown unknown unknown
   

Sto valutando di seguire il tuo esempio e di farmi un bel laptop mac da affiancare all'imac. Spero di leggere presto le tue esperienze.

Buona Mela anche a te....

PS: Ma non dicevi che i mac sono delle mega chiavi HW per far girare osX? come mai questa migrazione seppur mirata a scrivere un post' sul tuo blog?

Micky

ps: ma ce la mangiamo questa pizza prima o poi?

   
7. Shance
lunedì 2 giugno 2008 alle 1:08 PM - unknown unknown unknown
   

@Paperino

Spieghi meglio il problema dello schermo nero? Quando accendi ti rimane nero? Subito, dopo un pò, al riavvio?

Hai messo BootCamp 2.1?

Sinceramente non mi capita, avevo degli arresti durante l'installazione di Windows, risolti con una procedura forzata: www.sandeisacher.net/.../leopard-e-bootc

   
8. zakk
lunedì 2 giugno 2008 alle 3:30 PM - unknown unknown unknown
   

[quote]

Chi dice che i formattoni non sono richiesti per Mac?

[/quote]

E vabbè... preferiresti poter accedere al sistema pur non essendo in possesso della password?!?

se non sai la password un formattone è il minimo... e vorrei anche vedere...

(potrei raccontarti una storia da incubo di un formattone riparatore che ho dovuto fare su vista, a causa di un conflitto con daemon tools, ma te la racconto un'altra volta...)

   
9. Paperino
lunedì 2 giugno 2008 alle 4:45 PM - unknown unknown unknown
   

@Micky:

il fatto che io abbia comprato la dongle non vuol dire che il Mac non è una dongle a tutti gli effetti. Per la pizza potrei essere libero questo giovedì sera, vediamo che dice il capitano Satta.

@Shance:

se riavvio da Windows, il PC fa il suono tipico dell'accensione e poi durante il boot lo schermo rimane nero. Il boot sembra come se non sia nemmeno cominciato perché se premo il tasto power senza aspettare i classici 4 secondi si spegne. E all'avvio successivo Windows neanche mostra di essere partito (cioé non appare il menù di recovery tipico dei boot interrotti). Credo che sia un problema di boot camp o di firmware: proverò la 2.1, ma perché Apple Update non me lo segnala?

img183.imageshack.us/.../my.php

@zakk:

ovviamente il mio tono era ironico.

Di Daemon Tools penso tutto il male possibile.

Daemon Tools -> Blue Screen (addirittura su XP) -> voglia di tanica di benzina.

   
10. dovella
lunedì 2 giugno 2008 alle 4:47 PM - unknown unknown unknown
   

Zakk

per daeomon tool o alchol 120% non avevi la versione per Vista

in caso contrario non avresti avuto problemi.

   
11. sirus
lunedì 2 giugno 2008 alle 5:50 PM - unknown unknown unknown
   

Per risolvere il problema dell'orario Enrico, che conosciamo tutti , ha fatto un post piuttosto interessante sul suo sito: imieiguaiconvista.blogspot.com/.../ma-che-ora-e.ht .

   
12. sirus
lunedì 2 giugno 2008 alle 5:51 PM - unknown unknown unknown
   

Dimenticavo, benvenuto tra i Mac user... quelli che non sono fanboy ovviamente!

   
13. Shance
lunedì 2 giugno 2008 alle 6:26 PM - unknown unknown unknown
   

@Paperino

Il BootCamp 2.1 non viene aggiornato tramite Aggiornamwento Software. Non chiedermi il perchè, ci sono cose che Apple ritiene che non dobbiamo sapere.

Stando alle poche informazioni che abbiamo, sembra necessario per il corretto funzionamento di Windows con i suoi ultimi Service Pack e con la versione a 64bit di Vista. Non credo risolva il problema, sembra prorio una questione di boot.

Da Mac OS X hai aggiornato i firmware?

   
14. Paperino
lunedì 2 giugno 2008 alle 6:45 PM - unknown unknown unknown
   

@sirus:

grazie per il benvenuto. Purtroppo approfondendo le indagini non sono così convinto che quella voce di registry sia una buona soluzione. Vedasi: blogs.msdn.com/.../224672.aspx

Sto pensando a due possibili soluzioni:

1. che Apple sistemi il layer di emulazione BIOS in boot camp. L'aveva promesso per la 10.5.2 quindi potrebbe accadere.

2. che si possa scrivere un device driver che intercetta le chiamate al RTC per Windows e agisca di conseguenza. Forse in questo caso qualche ragno dal buco riesco a cavarlo.

@Shance:

si ho aggiornato il firmware. Stasera do' un'occhiata.
P.S. Non sono l'unico: http://discussions.apple.com/thread.jspa?threadID=1502568&tstart=0

@Edward:

ho installato i driver ATI modificati sul vecchio DELL ma niente, ottengo comunque lo stesso risultato. Forse è una questione di memoria: diversi tool riportano diversa quantità di memoria.

   
15. Edward
lunedì 2 giugno 2008 alle 9:32 PM - unknown unknown unknown
   

Le X1300 Pro PCIe e AGP, versione desktop, raggiungono 3.5 punti, quella PCI 2.8 (limitazione del bus pci: le prestazioni 3D sono sempre 3.4 - 3.5) [1]: probabilmente le frequenze del chip e della memoria del tuo modello sono piu' basse rispetto alla versione desktop oppure (purtroppo accade) la configurazione della ram e' creata in modo da utilizzare 4 chip di ram al posto degli 8 massimi e limitare il bus a 64 bit, penalizzando la banda per le texture. Il mio portatile ha una X1400, 450 MHz il core e 700 MHz la ram GDDR2: sarebbe l'equivalente di una X1300 XT desktop se ... il bus non fosse a 64 bit anziche' 128, annullando l'incremento delle prestazioni

L'unico modo per scoprirlo e' aprire il portatile, trovare i chip della ram e cercarne il datasheet: nel mio caso sono 4 chip Infineon/Quimonda con 16 bit di addressing per ogni chip. 16 * 4 = 64 bit; evidentemente Acer ha voluto risparmiare un po' sulla ram oppure aveva uno stock di chip 256 Mbit con 16 bit di addressing ...

Quanto alla rilevazione della ram, quella dedicata e' molto probabilmente 128 MB: tutta la memoria eccedente e' ram di sistema che viene utilizzata dal chip quando occupa quella dedicata, nella pratica l'equivalente nel bus PCI-Express del vecchio AGP Aperture Size. Per ATI l'accrocchio si chiama HyperMemory, per nVidia e' Turbocache ma in entrambi i casi consente di dichiarare quantita' di ram allucinanti ed irrealistiche sulle schede di fascia bassa ...

Ultima nota: per scoprire le frequenze di funzionamento puoi utilizzare Ati Tray Tools [2], un comodissimo diagnostico/tweaker tuttofare per schede Ati.

Edward

[1] www.tomshardware.co.uk/.../234119-34-post-

[2] www.guru3d.com/.../ati-tray-tools-

   
16. FDG
martedì 3 giugno 2008 alle 12:31 PM - unknown unknown unknown
   

A quel punto un gran bel formattone e installazione flawless di Leopard: chi dice che i formattoni non sono richiesti per Mac

Beh, credo che il formattone lo meriti chi non ti ha dato la password

Note negative: il layout della tastiera assurdo

Non è assurdo per principio. È una scelta diversa a cui ci su può abituare (io cambio in continuazione, quindi...). È come il CTRL per le shortcut. In origine era il CMD (o per chi preferisce MELA). Poi venne qualcuno (chi?) e decise che preferiva CTRL. E tutti la seguirono. Ora CMD sembra una scelta assurda (in questo caso dal punto di vista ergonomico è vero il contrario).

Comunque, vedo che hai già scoperto macosxhints

Senti... piuttosto che partizionare il disco interno, perché non provi ad installare Vista su un disco esterno USB? Questa è la soluzione che prevedo di usare io. Non ho ancora provato.

   
17. FDG
martedì 3 giugno 2008 alle 12:37 PM - unknown unknown unknown
   

p.s.: ti consiglio di installare comunque i developer tools.

   
18. Paperino
martedì 3 giugno 2008 alle 5:30 PM - unknown unknown unknown
   

Poi venne qualcuno (chi?) e decise che preferiva CTRL.

IBM? Comunque hai ragione ci si abitua, però il layout (la disposizione dei tasti) non è molto ergonomica. Ad esempio mi sarebbe piaciuto avere tasti separati per HOME, END, PG xx e il mitico DEL.

Senti... piuttosto che partizionare il disco interno, perché non provi ad installare Vista su un disco esterno USB? Questa è la soluzione che prevedo di usare io. Non ho ancora provato.

Per motivi di prestazioni e soprattutto perché odio i guinzagli USB

p.s.: ti consiglio di installare comunque i developer tools.

Link? Altre domande: ma c'è documentazione super tecnica su come funziona l'emulazione BIOS di boot camp? VMWARE, Parallel o Virtual Box? L'obiettivo - oltre ad usare VPC come sandbox - è quello di usare le applicazioni Windows su Mac. VMWARE sembra supportare l'uso della partizione bootcamp (che a questo punto continuerebbe ad essere backuppata sull'Home Server). Altre considerazioni?

   
19. Enrico
martedì 3 giugno 2008 alle 9:24 PM - unknown unknown unknown
   

@Paperino

Ti confermo che VMware (la versione per Mac è VMware Fusion) consente l'avvio di Vista installato nella partizione di bootcamp da Leopard (senza eseguire il reboot).

In pratica puoi scegliere se avviare Vista facendo il reboot oppure avviando (lo stesso Vista) all'interno di una macchina virtuale.

Tra l'altro combinando la modalità a tutto schermo di VMware con Spaces e con la possibilità di configurare gli angoli attivi dello schermo puoi ottenere una gestione della VM veramente comoda.

Anche se usare software di virtualizzazione con un notebook non è mai consigliabile a meno di non essere consapevolei del notevole degrado di prestazioni a cui si va incontro...

"Altre domande: ma c'è documentazione super tecnica su come funziona l'emulazione BIOS di boot camp?"

Cos'è, hai scordato di inserire l'indicazione <modalità ingenuità ON>?

Non pare anche a te che sarebbe una bella mano per chi si affanna a patchare Leopard per farlo funzionare sui cosiddetti hackintosh?

   
20. sirus
martedì 3 giugno 2008 alle 9:28 PM - unknown unknown unknown
   

Virtual Box su Mac OS X non lo consiglio come invece fare su Windows, se devi scegliere un virtualizzatore io punterei su VMware Fusion che offre prestazioni un po' superiori con Windows Vista e nel frattempo offre un miglior supporto alle distribuzioni Linux.

   
21. FDG
martedì 3 giugno 2008 alle 9:37 PM - unknown unknown unknown
   

Ad esempio mi sarebbe piaciuto avere tasti separati per HOME, END, PG xx e il mitico DEL.

Ah, il DEL! Un suggerimento da mac user sarebbe: SHIFT+DEL! Se fossi abituato al mac ti sembrerebbe logico (al pari di CMD+SHIFT+Z). Però purtroppo l'intefaccia del mac è stata sporcata un pochino dal software CMD+Y.

p.s.: ti consiglio di installare comunque i developer tools.

Link?

Dovrebbero già essere tra i dischi d'installazione del 10.5. Comunque, li trovi tra i file pubblicati nell'ADC Member Site (registrazione gratuita):

http://developer.apple.com/

Già che ci sono, ecco un link per te:

images.apple.com/.../Leopard_Securit

Ho letto l'inizio e sicuramente ti piacerà. Mi raccomando, fagli le pulci

   
22. Paperino
martedì 3 giugno 2008 alle 11:13 PM - unknown unknown unknown
   

@Enrico:

sarò tonto ma non sono riuscito a trovare il modo di indicare a VMWare di usare la partizione di boot camp durante il wizard.

Per quanto riguarda il BIOS sarebbe vero il contrario. Siccome l'emulazione BIOS serve a bootare Windows/Linux non credo che ci sia interesse di hackeraggio. Infine ho fatto l'aggiornamento al firmware 1.4 e il problema del reboot è peggiorato: prima dell'aggiornamento lo schermo si "spegneva" dopo lo "schermo grigio", ora si spegne addirittura prima del suono iniziale.

@FDG:

bhé se Apple spera di "catturare" un po' dell'utenza Windows dovrebbe cercare di venire incontro alle esigenze Ad esempio con un trackpad con 2 tasti: con un solo tasto non si può simulare la pressione del tasto centrale che in Windows serve ad aprire il link in un tab diverso.

Il documento sulla security l'avevo già visto cercando per documentazione.

   
23. Edward
martedì 3 giugno 2008 alle 11:37 PM - unknown unknown unknown
   

@ Paperino: Apple vuole si catturare l'utenza Windows, ma preferirebbe di gran lunga vedere utilizzato OS X.

E' come chiedere al produttore di auto con il cambio automatico se, per attirare clienti abituati al cambio manuale, prevede di passare al cambio sequenziale oppure utilizzare una leva che ricordi il pomello del cambio anziche' la manetta di un jet: campa cavallo ...

I mouse usb non funzionano?

Edward

   
24. Shance
mercoledì 4 giugno 2008 alle 12:58 AM - unknown unknown unknown
   

@Paperino

Peccato per il firmware, hai fatto la procedura "spegni e tieni premuto il tasto di accensione finchè non senti dlong e attendi che la barra di scorrimento completi il suo tragitto"? Ovvio di si immagino...

Hai impostato fisso come disco di boot quello di Windows? Se tieni di boot quello del Mac e schiacci tutte le volte alt il problema rimane?

Spiacente ma non ci sono tante KB per risolvere problemi di questo tipo, è una situazione frustrante e io ne so qualche cosa.

Per il tasto destro del trackpad devi tenere appoggiate le due dita e premi il pulsantone, è il tasto destro. Va abilitato nelle preferenze di distema. Cosa intendi con il tasto centrale?

VMware vede automaticamente la partizione bootcamp, per fartela mettere sotto backup da tm devi però aggiornare all'ultima versione (o penultima se è uscita una 1.1.3).

Dimenticavo, la partizione fat32 o ntfs l'hai formattata velocemente o in modo rapido?

   
25. Paperino
mercoledì 4 giugno 2008 alle 2:13 AM - unknown unknown unknown
   

@Edward:

sì i mouse USB funzionano, ma sono scomodi da usare sparapanzati sul divano. Oltre all'odioso effetto guinzaglio.

@Shance:

Peccato per il firmware, hai fatto la procedura "spegni e tieni premuto il tasto di accensione finchè non senti dlong e attendi che la barra di scorrimento completi il suo tragitto"? Ovvio di si immagino...

Sì e il firmware si è aggiornato correttamente.

Hai impostato fisso come disco di boot quello di Windows? Se tieni di boot quello del Mac e schiacci tutte le volte alt il problema rimane?

non so se ho provato ma immagino di si. Credo che il problema sia descritto nel forum: l'emulazione BIOS non resetta correttamente la scheda grafica e quindi quando l'EFI prende il controllo si blocca. Questo succede prima ancora che si avvii il boot. Proverò comunque a vedere se si lascia di default la partizione Mac.

Cosa intendi con il tasto centrale?

Con un trackpad a due tasti se premi i due tasti contemporaneamente ottieni un effetto diverso. Con IE7 significa aprire il link in un TAB diverso. Con il trackpad ad un solo tasto è difficile fare altrimenti; peccato perché mi ero abituato.

Dimenticavo, la partizione fat32 o ntfs l'hai formattata velocemente o in modo rapido?

Credo sia stata formattata in modo rapido dal CD di Restore di WHS.

   
26. Shance
mercoledì 4 giugno 2008 alle 2:23 AM - unknown unknown unknown
   

@Paperino

Apple vieta di usare quel tipo di formattazione, devi formattarla in modo completo.

Provi per favore?

   
27. Franco
mercoledì 4 giugno 2008 alle 8:31 AM - unknown unknown unknown
   

@Paperino

Qui in italy ci stiamo scervellando per te, poi trovo procedure dalle tue parti...

Guarda se ti e' utile per l'orario, devi fare tutto da lato mac, penso sia uno script all'avvio che regola l'ora, lato Windows non c'e da far nulla.

www.tuaw.com/.../tuaw-tip-settin

   
28. Enrico
mercoledì 4 giugno 2008 alle 11:31 AM - unknown unknown unknown
   

@Paperino

Non perdere mai la prospettiva: d'altronde si tratta di un downgrade....

E just it works è il slogan pubblicitario per gonzi.

   
29. FDG
mercoledì 4 giugno 2008 alle 11:42 AM - unknown unknown unknown
   

@Paperino

bhé se Apple spera di "catturare" un po' dell'utenza Windows dovrebbe cercare di venire incontro alle esigenze Ad esempio con un trackpad con 2 tasti: con un solo tasto non si può simulare la pressione del tasto centrale che in Windows serve ad aprire il link in un tab diverso.

Il click sul tasto centrale purtroppo non è di grande utilità su un mouse che ha come tasto centrale una pallina (provare per credere). Per cui non è una soluzione praticabile.

Le combinazioni di tasti che si possono usare sui link sono:

CMD+CLICK -> apre un nuovo tab dietro

CMD+CLICK -> apre un nuovo tab e lo porta avanti

ALT+CLICK -> scarica il file collegato

CTRL+CLICK -> menu contestuale

SHIFT+CLICK -> apre una nuova finestra

Le prime quattro combinazioni funzionano sia su Firefox che su Safari; l'ultima funziona solo su Firefox; Opera ha la seconda e la quarta combinazione invertita. Non ho provato gli altri browser per mac, cioè iCab, Camino e OmniBrowser.

Più coerenza non guasterebbe. Bisognerebbe convincere gli sviluppatori a mettersi d'accordo.

@Shance

Per il tasto destro del trackpad devi tenere appoggiate le due dita e premi il pulsantone, è il tasto destro

Ma non funziona solo sui nuovi macbook?

   
30. Franco
mercoledì 4 giugno 2008 alle 2:37 PM - unknown unknown unknown
   

@FDG

Funziona tranquillamente anche sul mio ibook 12 pollici da dove sto scrivendo ora, ci vuole Leopard pero'

img238.imageshack.us/.../21287347gt0.jpg

   
31. FDG
mercoledì 4 giugno 2008 alle 6:59 PM - unknown unknown unknown
   

@Franco

Ok, allora mancano solo zoom e rotazione.

   
32. FDG
mercoledì 4 giugno 2008 alle 7:06 PM - unknown unknown unknown
   

Mi correggo: zoom immagine, rotazione, scroll e navigazione.

dezone.files.wordpress.com/.../immagine-2.png

   
33. Franco
mercoledì 4 giugno 2008 alle 8:52 PM - unknown unknown unknown
   

@FDG

PORCA VACCA! Hai un Pro nuovo o l'Air o l'hai presa da qualche parte? Maledetto....!!!

   
34. FDG
mercoledì 4 giugno 2008 alle 11:28 PM - unknown unknown unknown
   

@Franco

Guarda, ho dato via un iMac, un Mac Book ed un po' del mio sangue per averlo.

   
[ Pagina 1 di 2  - più vecchi ]
Lascia un commento:
Commento: (clicca su questo link per gli smiley supportati; regole di ingaggio per i commenti)
(opzionale, per il Gravatar)